Atom无法运行Dart文件

刚回老家,在家里的电脑上装了Atom
关于编辑器
终端环境的话还是Vim/Emacs
但桌面环境的话,Atom将创造神话

然后测试了一下代码,但突然发现无法运行
右键菜单中没有运行选项
工具栏的运行按钮显示“No runnable apps

折腾半天,又重装了相关的package
还是不行,感觉是Atom没有识别到项目类型
然后试着添加了pubspec.yaml文件
dart文件的右键菜单突然就跳出来了Run、Pub get等选项

Atom自动创建了项目运行的配置文件

再回到dart文件,工具栏的相关功能正常显示!

本文出自“Dart语言中文社区”,允许转载,转载时请务必以超链接形式标明文章原始出处
本文地址:
http://www.cndartlang.com/511.html

发表评论

登录后才能评论